Jump to content

Buick Reatta Discussion Forum

A forum for discussing and sharing information about the Buick Reatta. Come in and make yourself at home!


725 topics in this forum

  1. Favorite Buick Reatta Photos 1 2

    • 35 replies
    • 2.9k views
  2. Favorite Buick Reatta Videos

    • 18 replies
    • 1.3k views
  3. Teves ABS Brake System explanation

    • 8 replies
    • 1.4k views
    • 121 replies
    • 820 views
  4. Cruise control performance + boost?

    • 2 replies
    • 35 views
    • 0 replies
    • 26 views
    • 2 replies
    • 38 views
  5. Almost all problems solved.

    • 0 replies
    • 24 views
  6. Just purchased a 88 reatta randomly. 1 2

    • 37 replies
    • 549 views
    • 4 replies
    • 351 views
  7. Our Non Reatta Cars & Trucks

    • 5 replies
    • 87 views
  8. E041 code, advice

    • 9 replies
    • 85 views
  9. What did you do with your Reatta today. 1 2 3 4 21

    • 411 replies
    • 14.8k views
    • 5 replies
    • 169 views
  10. Reatta daily driver

    • 2 replies
    • 53 views
  • advertisement_alt
  • advertisement_alt
  • advertisement_alt


  • Recent Posts

    • Ronnie
      Some of you may remember me posting about this problem. I had the same thing happen on a hot day when I was going around a scenic, 11 mile, loop through the Smoky mountains National Park. I was in bumper to bumper traffic moving about 5 miles per hour with a lot of stopping and starting to look at wildlife requiring me to do a lot of brake pumping. When I was almost at the end of the loop the brake pedal started chattering like the ABS was engaging and then the power boost went out completely. Both brake warning lights came on.   Luckily I was near a wide place in the road where I could pull over near an old abandoned log cabin. The pump wasn't running. I looked everything over and decided too much heat under the hood might have caused the problem. I swapped out the relays on the firewall but that didn't help. I left the hood open and we went and sat on the porch of the old cabin for about 30-45 minutes to allow the brake system to cool off. When we got back in the car the brakes worked fine. It has never happened since.  I don't know for sure what caused the problem.
    • DAVES89
      I would tend to agree and besides if the relays are original they are a cheap part and easily swapped. You will need two. One for the ABS and one for the entire brake system.
    • buickron
      1990 Reatta Coupe:  My braking system fails when outside temperatures are around 90 -95 degrees, or when the engine compartment gets hot when idling.  I've been told that the failure may be related to corroded relays or relay failure.  I still have some braking with difficulty.  ABS and brake lights come on when the system doesn't work.  Comments?
    • 2seater
      Probably true but it went to the right person 👍 He also replaced the left outside tie rod end last week but I figure that as normal maintenance.
    • DAVES89
      I'm starting to think I got rid of it at just the right time...
×
×
  • Create New...